Bug fix for both free & premium mail forms

I’ve just released a minor bug fix for both the free and premium versions of Jem’s Mail Form. JMF free is now on version 2.4.5 and JMF Premium on 2.1.2.

In certain rare circumstances where no required fields are entered, the form previously always threw up the “please fill in all required fields” error message.

$requiredFields is now checked to make sure fields are actually required before testing contents.

This is a non-urgent fix and you do not need to update if all of your forms have required fields.

(Please note: although I’ve fixed this bug for very specific circumstances, I recommend that at least one field is always set to required to prevent potentially empty submissions.)

This entry was posted in Updates, on March 16, 2017

  

Comments are closed.

Get Premium

All the great features of the free contact form, and more besides...

Buy Now - £19

  • UTF-8 support: ideal if you receive mails containing characters such as é, õ, and so on
  • Even more spam protection: take advantage of better functionality in newer versions of PHP
  • Repeat submission protection: stop people from submitting the form multiple times in a row